Testing More Aggressive GRBL Settings

Hey guys, I’ve been playing around with some modified GRBL settings for awhile now with the hopes of one day convincing Rob to open up the throttle a bit more on default machines. Please consider these “beta” settings, but if you’d like to test them on your Shapeoko I’d welcome any feedback.

Here are the parameters I’ve modified:

$25 = 1700 // Homing seek speed (for initial touch-off) that I run. If you haven’t flashed settings for your machine since 2018, you may be be at 1000mm/min which would be painfully slow on an XL or XXL. In documentation we’ve suggested 1500mm/min, and in recent builds it may even have been bumped to 2000mm/min. This setting isn’t a big deal, but wanted to give a heads up to anyone rocking the OG grbl settings from launch.

$27 = 1 // Homing Pull-Off reduced, this makes homing super quick. You can use 1.5 or 2mm if you don’t trust your switches or deceleration, but I haven’t seen any issues from this on my machines.

$110/111 = 10000 // X and Y max rate doubled. 5k mm/min was less than 200 IPM. That’s super slow if the machine is repositioning for a new cut on a big project, or even small but numerous repositioning moves in adaptive toolpaths. I would not program any hard cuts at these feedrates, but for rapid (non-cutting) movements these should be safe.

$112 = 1400 // Z max rate for HDZ only. The default is like 1000 or 1200 which is kinda slow, especially if you use Fusion which can plunge fast before slowing down for entry. Above 1500mm/min you’ll want to double check your rail alignment, to ensure sliding resistance is sufficiently low. Would not recommend going above 2k.

$120/121 = 500 // X and Y acceleration increased 25%. I know @Vince.Fab has pushed way more aggressive settings, but baby steps for now… The 400mm/min^2 values have been unchanged since launch, so I have a better shot convincing Rob to make a modest change first…

$122 = 200 // Z-axis acceleration for HDZ. Not sure if this is default or not, but its what I use. Acceleration and feedrate are coupled, so adjusting one may affect the other.

Let me know if you run into any problems with these settings, and/or if you’ve successfully and reliably pushed more aggressive motion parameters. Also please indicate if results for Z are with stock or HDZ where relevant.

23 Likes

I am wrapping up my HDZ upgrades. I would be willing to try these. Will report my results when I have some.

3 Likes

I’ve previously used $122=200 before with good results with the HDZ. I backed off after I checked with Luke but I never had an issue with it at 200.

1 Like

Interesting. I’ve been running with it $122=400 for over a month now with no issues. It’s what I ran on my prior z-axis so I just carried it over. Am I missing something that anyone sees when it’s that high?

1 Like

Awesome @wmoy

Will be updating the XXL at work accordingly
Figured there was some speed left and appreciate you doing the legwork.
Particularly fond of the non engagement travel speed increase

3 Likes

Not sure honestly. I started with both feedrate and acceleration high, and brought them down in tandem. Have not tried high acceleration with the more moderate speed. If it hasn’t been problematic for you though, great.

1 Like

Does CM still allow these to be set directly? I used to manually override these in earlier versions (CM3, etc) but haven’t in a while since it added the automatic machine setup and even lets you click if you have bitsetter and HDZ. I guess I should write all these settings to a file in case I accidentally update it again.

I have never understood why the default settings in CC and CM are so painfully conservative - I just assumed it was because the Nomad is Rob’s first baby and he didn’t want it to see that much less powerful than a Shapeoko :slight_smile:

People still manage to get themselves in trouble with the stock settings. C3D has traditionally erred on the side of too many training wheels rather than too few.

You can program in new GRBL settings in the MDI interface in CM.

2 Likes

For the sake of illustration, here’s a (very, very bad quality) video about how my SO3 behaves with those settings:

I never bothered to tune them before, but I must say this feels like I have a new machine. Go and upgrade those settings now !

5 Likes

Hey Julien. I made all the GRBL changes, double check with log files, all seems good , but no changes happened:( Am I missing something?

Thanks

Would love a setting in CM to switch to these more aggressive grbl settings.

4 Likes

Weird. I did my test using CNCjs, not CM, but I don’t see how that would affect the results.
You don’t see any change in either jog speed or homing behavior ?

Yes, I used CM and didn’t see any diff in either job speed or homing:(

Anyone else have this issue?

I have not tried yet but @wmoy specifically said CM so he must have tried using CM. JUst for the sake of completeness, what version of CM are you using?

CM Version 4.0.428. Maybe works only with beta?

Not likely.
By any chance, did you mistakenly click “Send Config Data” after your changes ?

431 is the current version.

1 Like

Weird, on Mac OS and says “no updates available”, will have to download…

Thanks

I don’t think that Mac O/S actually looks for updates of Carbide programs, you have to go manually to check if any are available. https://carbide3d.com/carbidemotion/download/

Aaah, GTK, thanks!:slight_smile: