Problem with file

I spent all day in the shop yesterday. Ran 4 different projects on the Shapeoko. Had no issues with any of them. All files different projects. This one particular project I have attached, will not run correctly. I have set the zero multiple times (at least 6 attempts), and done it for both cut files for this project. But every time I hit run, the tool raises up about 2 inches, goes to position and starts moving but it stays about 1.5" above the wood. I have disconnected the laptop, cut power to the tool, I got up this morning and tried again, I have reviewed everything that I can think of in the file, and I can’t find anything. The only difference I know in this, is I had a graphics person redo this drawing from an original. When she sent it to me, she sent it to me as this file already in carbide create. Don’t know what that has to do with it. Anyway, thanks for the help, trying to get this project finished today for Christmas present. Thanks
SwatLogo_Dec17Update.c2d (913.6 KB)

Mike, can you also post the generated g-code file you ran ?

ok so 2 issues Id fix urgently

  1. The file has the zero point set to the bottom of the stock. if you zero your piece at the top and not at the waste board that explains the air cutting
    (this can be changed in the “sprocket” screen where you also set the size of the wood etc)

  2. you have 1/2 inch of retract hight set… 0.1 or even 0.05 is much nicer given the limited Z height in our machines

1 Like

See,i took for granted looking through my details that I had everything set like I usually do, but since she sent me this file, I completely overlooked it. I just changed it and will give it a new shot in a few. Will let you know. Thanks!!

Could it be that you are near or have exceeded the GCode size limit for Carbide Motion? Have you tried to view the GCode simulation in CAMotics?

1 Like

You were exactly right! I overlooked the bottom vs top as the zero point. Once I changed that it worked perfect. I did encounter another issue once I did the cut. If you look at the image in CC, it shows all the leaves of the laurel branches there. But when it cut, on the right side, top of the laurel one of the leaves cut as just a line. I thought I had overlooked that as an image issue, but I just reviewed it and it does not show like that in CC. Suggestions? Again, you guys are great! Thank you for always helping and teaching!IMG_0027

1 Like

one thing I do to diagnose difference between what I think the design is and what comes out… is upload the gcode to and see what the software sends to the shapeoko… that basically halves where the problem could be

OK. That’s way above my head. I looked at the program but I have no idea what I am looking at.

you can see the visualization on the right of the page… that’s what to look at not so much the code

(also I wrote a tool for myself that converts the gcode back to SVG but more manual than a nice web page … there’s also programs like universal gcode sender that you can install locally will visualize the gcode for you)

so when i open the file how do i see the image? I opened the file but don’t know what to do from there to see it.

(just checking you sent it the .nc file right and not the .c2d)

for me when I upload .nc files I get a visual (3D-ish) on the right side of that page

I uploaded the file in carbide motion, whatever that is

If anybody has any more ideas for help on this, please let me know. Trying to get a project completed for a Christmas gift. Thank you!

I find the easiest to use G-Code previewer to be CAMotics (actually sent in a donation):

It installs locally, and if associated with .nc files, one just has to double-click on them for a quick preview:

I made an XML file which has the definitions for most Carbide 3D tooling and posted it to the CAMotics user group:!forum/camotics-users!topic/camotics-users/0GLqFDkJm18

and it’s on Gitub:

1 Like

Ok, I appreciate all of it, but what does this mean? In CC it doesn’t show like that, in your screen shot it does. What does it mean and how do I fix it? I know nothing about gcode. Thank you

so your gcode matches your cut out wood? If that’s the case the issue is on the CC/design side not the machine/physical side…
means the problem has been halved :wink:

1 Like

I generated the G-Code using Carbide Create 445 — and it matched the preview in that — please try it:

OK, I see there is a new version of CC. I assume you are saying I need to do it in the new version? I opened your link and installed the new version. I have created my design in it with that logo. However, in CC it does not give me options for wood and the tool library is pretty much empty and I don’t see how to add anything. Thanks

For feeds and speeds the router speed setting should match the feeds and speeds for your selection of endmill and material. Please see:

(there’s a row matching dial settings to RPMs at the bottom)

There’s an interactive version at:!/vizhome/Carbide3DCNCFeedsandSpeeds/Sheet1?publish=yes Note that the feeds and speeds in Carbide Create are updated for trim routers in 433 and later:

See for concepts on this and see the series #MaterialMonday: #MaterialMonday on YouTube for specifics.

You should test feeds and speeds in a piece of scrap using the technique at:

Another consideration is Climb vs. Conventional Milling and tooling engagement — where possible avoid slotting and add geometry and cut as a pocket (Adding geometry to cut as a pocket with a finishing pass ).

Extensive discussion at: Origin/consistency of chipload recommendations and with a spreadsheet for this at: Speeds, Feeds, Power, and Force (SFPF) Calculator

Duplicate a library with a suitable name, then modify the feeds and speeds to match what you want — you can do this in the app, or by editing the CSV in Excel (do Help | About | Open Data Directory)