Pulley set screws came stripped?

I recently purchased a Shapeoko XL and I tried my first cut on Maple with a 5.5 mm 4 flute bit.

The cut in the air works as expected.

But when it hit the wood, it started going bad real quick. The cut is suppose to surface the wood only 1 mm, but the cut kept going deeper in the Z-axis 2mm, 3mm, then just went off path on the X Axis.

I am going through troubleshooting, and wanted to tighten my set screws. But I found 1 screw on the x-axis that won’t engage with the hex key.

I am planning to buy these heavier-duty screws, https://www.mcmaster.com/93705A814 but I don’t expect them to help if I can’t remove a current one.

Any advice?

You might have to drill it out. But first, is it loose? if not, skip it.
Use some locktite on these when you put the new one’s in.

1 Like

I can’t remember what size the set screw thread is on the pulleys, but if it’s M3, this ought to work for you:

A regular screw extractor set with a small enough extractor might also work, depending on how deep the set screw is in the pulley.

Also, if you really want to replace the set screws with socket head screws like in the link you provided, you might want to consider alloy screws rather than stainless because they are much stronger.

The pulley set screws are standard M3 set screws, ~4.75mm o.a.l. — folks replace them with M3 SHCS or a suitable length, (8–10mm works well).

If you can’t budge the screw to tighten/loosen, and it’s holding securely, I’d leave it (let sleeping dogs lie and all that — the difference between good and better is not nearly so well defined as between bad and worse).

If it’s really a problem, contact us at support@carbide3d.com and we’ll send you a replacement pulley w/ set screws which you can replace.


Gets my vote for ‘Quote of the Year’!


Yeah, I recommend you just talk to Carbide3D. I’m not sure why you would jump to buying some ones that you don’t know will work versus just talking to them and they ship you some ones that will work. Trust that Carbide3D will support their products 100% and that Will knows how to make things magically appear on your doorstep in 2 days.


Its hard to know if it’s loose if I can’t engage it.

I did troubleshoot other issues, but haven’t had any joy yet. I found my Z had some slop, fixed it, but I still seem to have Z issues. My third cut the Z seems to be skipping cause it got more and more shallow. I wonder if my Z belts are too tight?

Each of these pockets are suppose to be 2.75mm…(trying on plywood now)

From my experience, a belt is almost never too tight.

You may want to try and draw a line (with a black marker or white paint or whatever) across the shaft & pulley, like so:
then repeat the cut where you are losing depth at each pass, and check if the line on the pulley/shaft is not aligned anymore (then you’ll know for sure that the shaft is slipping)

Another possible (but less likely) explanation could be that the endmill is slipping in the router collet ?
Re-reading your initial post I see you were using a 5.5mm bit (I had no idea this diameter existed), sorry for asking but what is the size of the shank and did you use an appropriate collet size matching that exactly ?


Agree with others that you should begin by checking the machine mechanically :

It is also important to be sure that the collet is correctly tightened, the endmill fits correctly and doesn’t slip, and the router is mounted securely in the mount, and that the mount doesn’t shift. Note than endmill pullout can happen gradually, especially when profiling against tall walls.[4]

Also feeds and speeds may be a consideration: https://docs.carbide3d.com/support/#tooling-support and see https://www.youtube.com/watch?v=S9bceJxpqG0 for concepts on this and https://www.precisebits.com/tutorials/calibrating_feeds_n_speeds.htm for a testing technique and see the series #MaterialMonday: #MaterialMonday on YouTube

Beyond that it’s usually a matter of ​Calibration and Squaring the Machine c.f., http://docs.carbide3d.com/shapeoko-faq/how-to-calibrate-the-machine-for-belt-stretch/


I had similar problems with my Z pulley set screw. I pulled out the pulley, drilled out the set screw and put a larger one (4mm) in place but you can use a cap screw as they will not interfere and are easier to torque since the hex head is larger.

1 Like

Yay got my first successful cut, albeit with speeds and feeds reduced to 33% recommended in Carbide Create.

I think the issue was the collet wasn’t tight enough, although I tightened everything mentioned before this last cut so hard to know for sure.

1 Like

Something that caught me out early on was I had the router set too high in the mount, and thr z axis was actually travelling too far down and skipping - just confirm that at the lowest point the bottom set of v wheels aren’t going past the bottom of thr extrusion they travel on


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.