Shifting off track

Note: I started this post several months ago when I set up the machine for the first time, but due to COVID & Summer vacation (I am a teacher), I haven’t been back in front of the machine for a few months. If you are one of the people that responded to my earlier posts, I would love to continue the conversation and learn where I am making my errors.

As I am running the machine, it will frequently shift off track with the cut. The strange thing, is that it shifts back for the majority of the pass. To try to explain better, if I am cutting a square, the first several passes run just fine. Then as it is cutting, it shifts one of the sides over an inch. As it finishes cutting that side, it shifts back to the original track. So it is not a permanent shift in the path, only for a portion of the path. When I stopped and repeated the program, it made the same error in the same spot as before. Then, to make things crazier, I ran the same program from a different computer and it ran just fine (I ended up having the same problem with a different file later on that computer, so it’s not the computer).

I am probably explaining this poorly, but hopefully the picture will help. I colored in the shifted track with a sharpie to see better.

Any help is greatly appreciated.

I can almost guarantee that this is a mechanical problem. I would verify that all the set screws in your pulleys are tight. After that, make sure your belts are tensioned correctly. It could also be missing steps but I think that’s unlikely.

1 Like

Shifts are usually caused by skipping steps. Make sure your belts are properly tensioned. If that doesn’t help, reduce speeds and feeds.

The machine can handle cutting forces up until a certain point until it skips steps. Larger diameter mills will reduce cutting force and shallower slower cuts will reduce cutting forces. Also if you do not clear chips, they’ll get wedged and also increasing cutting forces.

Both mentioned ‘skipping steps’. Can you please explain a bit deeper. (I am a complete newbie to this, and am learning as fast as I can to teach it in my STEM classes)

When a stepper motor skips steps it means that the torque required to turn the motor shaft exceeds the torque the motor can put out. The stepper will be sent a pulse but rather than moving a step, it will attempt and then snap back to some other full step alignment. Since a stepper is an open loop system, the controller will have no idea that this has happened and continue on its way thinking there is nothing wrong. Technically there are some advanced stepper drivers that can tell if you have lost steps but that is not the norm.

Skipping refers to two possible things: skipping teeth on the belt and skipping steps on the motor.

If the belt is too loose then it can be pushed off the motor shaft if the forces are too great. Similar to cam out you might experience driving those horrible X shaped screws.

Skipping steps refers to the motor changing the magnetic field to a new position, but the shaft doesn’t turn. Think about trying to push a magnet past another magnet. If you hold one magnet fixed, and push the other magnet past it (not directly towards), they’ll resist motion until it passes the inflection point where they’ll push each other apart. Same thing happens inside a stepper motor, but along a circular path.

Thank you for the explanations! I really appreciate everything. Question: If this is the case, would it return back to the original path after making the missed cut? Then on the next path (1 step lower) again go in the wrong path (just for the small portion), again to return to the original path?

I know this is confusing, and I appreciate your patience and help!

Once steps have been skipped, there is no guarantee anything will happen. It is extremely unlikely that it would return to the original path but not impossible. The machine is likely to continue skipping/losing steps because your endmill will be encountering material at a different depth or width than you planned. It could also start running into things it shouldn’t like clamps or parts of the machine itself. The location the controller thinks the spindle/router is in and where it is in reality could be wildly different. This is one of the disadvantages of an open loop system vs a closed loop system that has encoders to tell the controller how much the motor has actually moved. Open loop is quite a bit cheaper to do which is why you see it in things like consumer grade desktop CNC’s and 3D printers.

In your case, I don’t think you lost/skipped steps because not everything has shifted after that one problem. I really think that this is a slipping pulley on the motor shaft. This issue is more likely to show the behavior of going back and forth between the correct and incorrect path. In your picture, which way is X+ and Y+?

A further consideration is cutting a slot just as narrow as the endmill results in near constant 100% tooling engagement — best to add geometry offset around the part and cut as a pocket down to tab depth or the penultimate pass — where possible avoid slotting and add geometry and cut as a pocket (Making vacuum hose adapters and/or Adding geometry to cut as a pocket with a finishing pass ) and consider leaving a roughing clearance and taking a finishing pass.

The motors on the Shapeoko are what’s known as “open loop”, that is, the controller does not know if the motor turned when commanded or whether the relevant axis moved the requested distance. Stepper motors move a known angle (1.8 degrees in this case) per step and the controls exploit this.

When the machine first powers up it finds the home position by moving until it trips the switches at one end of the travel of each axis. This allows the machine to set an internal zero point for each axis and it then simply remembers how many steps it has requested up or down that axis to “know” where it is.

If something happens, a pulley slips or the motor is unable to step when requested, there’s no way for the controller to know this as there is no feedback system.

So once your machine has slipped off track, be that from a loose pulley, loose belt or simply too much cutting force, it’s going to be stuck over there until you re-initialise the machine.



Thank you for the great feedback! The pictures were rotated 90degrees on accident. The shift has been consistent in the x-axis (I can’t tell you if it’s always positive or negative shift however).

Thank you for your help, however I am going to admit I really don’t understand your advise. Are you able to please re-phrase in noobie terms? I appreciate it! I love learning about this machine, and I found I learn more from making errors than perfect productions.

If this is the case, then everything after the ‘slip’ would be off as well. This is not the case. It will cut one portion off track, then jump back on track right after. Then when it drops down to the next layer, it jumps off at the same exact point (then back on…rinse & repeat).
This is why I was wondering if the problem could be digital rather than mechanical?

My guess is a semi-loose setscrew on the X axis motor pulley.
It is not impossible that the pulley slips on the shaft in one direction (say, the setscrew is not quite pressed hard enough enough the motor shaft flat, so it slips), then it “catches” the shaft’s flat again, then the cutting direction changes and it will slip & catch once in the other direction…ending up where it started.
I agree it sounds unlikely, but I would still triple check the two setscrews on the X motor pulley, no harm in doing that anyway at least to rule out this hypothesis.


Will is basically suggesting you make the “trench” for your cut wider so that the endmill isn’t tight within the slot when it is cutting. It means it will cut with a smaller part of the tools radius, rather than about half of its radius.

That said, I’ve never had problems cutting exactly like you are doing.

There is a community-maintained glossary at:

Tooling engagement is how much of the cutting surfaces of the tool which can be involved in cutting are potentially bogged down in cutting.



I would say that about 90% of all issues with unexpected behavior when cutting are mechanical, especially with new users and machines. As @Julien and myself have said, please check the set screws on the X motor pulley. It is very likely the issue and if it isn’t you will rule out that possibility by checking…



My experience aligns with this. If you’ve not seen the hint already, taking a marker pen and drawing a line across the face of the pulley and the motor shaft is a great way to tell if it’s slipping on the set-screws.


Surprised nobody has mentioned the pulley set screw.


Guarantee that this your set screws on the pulleys. I documented the issue here that is the exact same as yours:

This is the full solve with parts you need to purchase (it’s only a few $).

This is a frustratingly simple fix. It’s a bad experience for a new user trying to learn a machine and track an issue like this. You get all this advice on how troubleshoot it and misdirection about material forces, speeds and feeds, and slotting. The short story: it’s a design flaw that Carbide3D could resolve.

I’m at a loss on how to get the Carbide3D team to implement straight out of the factory. It’s a near zero cost solution for them, switch out current inadequate grub screws with better cap screws and removable thread lock. I’ve tried escalating here and emailed support. I’ll try again emailing support.