Controlling with Microsoft Surface

I want to control my Shapeoko 3 with a Surface, but I’m having some problems. I can connect and initialize the Shapeoko, but when I go to do something like a rapid jog the router only moves a few mm then stops. I can move in small increments but that’s it. I have tried with a Surface 3 and a Surface Pro 4, both with the same results.

I have a Dell laptop that I can use but it is rather large for what I need.

I see that others have used a Surface as a controller, so I’m perplexed as to why I am having this difficulty.

Does this happen when you using the touchscreen? Does it happen with keyboard controls?

Which version or Carbide Motion are you using?

Probably the most expedient thing to do would be to get a numeric keypad or a gaming controller or a game pad (with keyboard remapping software) or a small custom keyboard:

This seems to happen when you haven’t sent the right config to the machine. Eg. xxl with a Z plus.


I’m using the touch pad on the keyboard, essentially a mouse. I’m running the latest version of Carbide Motion.

I’m simply connecting and initializing, then trying to do a rapid jog. Wouldn’t Motion know which type of machine it is connecting to and send the correct initialization?

For configuring the machine please see:

I don’t think it does, and with the 513 version I believe it is a step process. I will try and find @WillAdams instructions.

1 Like

As per above, Will beat me to it.

I’m already successfully using the Shapeoko with a Dell laptop and I want to switch over to using the Surface. Does this data get sent every time the Shapeoko is initialized?

It should only need to be done once, when the machine is initially configured EDIT: for a given computer — Machine configuration will need to be redone on each computer which is connected to a given machine.

I am using CM 521 and the defaults sent for an XXL, HDZ are incorrect for the HDZ. The defaults set 90 MM for the HDZ and Will Adams said to set it to 140/150. I set it at 140 and it worked fine. So your question of does Carbide3d know the default is yes but they wrote the defaults wrong so you could also answer the question does Carbide3d know the defaults as no. Hopefully it will be fixed in the next revision.

It should only need to be done once, when the machine is initially configured.

So it sounds like it is not a configuration issue then.

I have been following the raspberry Pi, posts. I believe it needs to be sent from the machine you want to use it from. As the laptop doesn’t know the settings.

This is from a comment @robgrz made

1 Like

As @Jasoni noted, it needs to be done once from each computer you use for a given machine. If you configured with the Dell, then repeat the configuration with the Surface so that the latter is set up to match your physical machine.

Thanks, I’ll try that tomorrow and report back.

I configured the settings from my Surface 3 and everything is working great now! Thanks for all the help.


This topic was automatically closed after 30 days. New replies are no longer allowed.