Using a Game Controller with CM513 and later

Unfortunately, my son left his at college, so I haven’t been able to test this until now (picked up one while doing a run for essentials since it caught my eye):

Picked up a:

(since apparently that is what was used for testing, and I don’t want to trouble over another battery to charge)

Only supported on Windows at this time. Initial setup requires plugging it in, and allowing the device to get setup.

Controls are active when in Jog mode:

Increment:

  • RB — increases current jog rate
  • RT — decreases current jog rate

Axis controls:

  • Z
    • LB — Z up
    • LT — Z down
  • X and Y
    • if mode is lit, these are controlled by the left thumbstick
    • if mode is not lit, these are controlled by the left directional pad

Not seeing any configuration options, if continuous (button down) jogging) stops working, going into and back out of settings seems to fix that — jogging also works for single button presses when CM is not foremost, so it not being foremost can cause this as well.

When active/setup there is a “Game Controller Enabled” message:

  • Logitech button — this brings up the Windows Game Bar settings
  • Mode — toggles between thumbstick and pad as noted above
1 Like

I hope in the future we can get some unused buttons and thumbsticks on the controller to handle pulling up the probe screen and scrolling through the drop down lists. Not really an issue for me as the tablet that runs my machine is right next to it and probing is easily handled by touch screen. I could see it helping with the workflow on other setups, though. Does anyone know how to switch the movement function from dpad to left thumbstick on an xbox one controller? I haven’t messed with it beyond plugging it in and jogging around for a minute.

1 Like

I tried a USB NES controller and it didn’t want to control anything. But I didn’t get the Gamepad enabled message. I will try it again.

2 Likes

Can the game controller also be used to start and pause a job? Or is it only for jogging?

1 Like

I don’t know, check in at: Gaming controller function for Carbide Motion w/ @robgrz

As far as I can tell, only motion with the controller.

1 Like

Has anyone had any luck with this on Mac yet? I am able to jog with both my PS4 controller and a steel series nimbus via bluetooth running CM4 on mac with a controller mapper running except both have the same issue of performing every command three times then stopping. They won’t jog continuously. A cheap $10 amazon bluetooth keyboard I had laying around works fine… Any ideas? If not, has anyone tried a custom arduino-based controller like “stream cheap”?

1 Like

This topic was automatically closed after 34 days. New replies are no longer allowed.

My understanding is the Mac version of Carbide Motion doesn’t have support for this at this time.

I’ve plugged in an 8bitdo N30 Pro which was found and configured automatically, and it shows as “GAMEPAD ENABLED” in CM and it has the following mappings:

  • L1 - Z-axis up
  • L2 - Z-axis down
  • R2 - speed increment slower
  • R1 - speed increment faster
  • D-pad works as expected for XY

but none of the other controls work.

Antimicro doesn’t allow remapping controller buttons, so I’m not going to get the simplistic layout I was hoping for, so will be going back to the Techkeys keyboard and the gamepad w/ remapping which is unambiguous enough and fewer dead controls.

1 Like

Ok, I’ve procured the game pad controller, downloaded a remapping * program as noted (anti micro-2.23-win32.mail). And this is where I’m stuck. Is there more in-depth “ how to”.? I believe the carbide cutter must be active and loaded. Any guidance would be very much appreciated. Tom

You have to make sure that Carbide Motion has the focus — I usually touch a dead area to ensure that it works.